Skip to Content

FAQ

What browsers do you support?

We support the following browsers:

  • Internet Explorer (current version)
  • Chrome (current version)
  • Firefox (current version)
  • Safari (current version)
  • iPhone and iPad (current version) browsers
  • Andriod browser (current version)

We do not support Internet Explorer running in "Compatability mode" or versions 6 or 7 due to their poor support for modern internet and security standards. Nor do we support any version of Netscape.

Back to FAQ